Ho trovato difficoltà ad installare il nuovo pacchetto debian skype (skype_1.2.0.17-1_i386_mod.deb) su Kubuntu. Alla fine ce l'ho fatta e condivido volentieri i piccoli passaggi fatti per installarlo correttamente.

Iniziamo dall'errore che avevo durante l'installazione:

dpkg: dependency problems prevent configuration of skype:
skype depends on libqt3c102-mt (>= 3:3.3.3.2); however:
Version of libqt3c102-mt on system is 3:3.3.3-7ubuntu3.

Ho risolto semplicemente indicando a skype di dipendere dalla versione 3:3.3.3 invece che dalla 3:3.3.3.2:

# cp skype_1.2.0.17-1_i386.deb skype_1.2.0.17-1_i386.deb.orig
# dpkg-deb --extract skype_1.2.0.17-1_i386.deb skype.tmp
# dpkg-deb --control skype_1.2.0.17-1_i386.deb skype.tmp/DEBIAN
# vi skype.tmp/DEBIAN/control

In control ho sostituito

[...] libqt3c102-mt (>= 3:3.3.3.2) [...]

con

[...] libqt3c102-mt (>= 3:3.3.3) [...]

Poi ho ricostruito il pacchetto e l'ho installato:
# dpkg --build skype.tmp
# mv skype.tmp.deb skype_1.2.0.17-1_i386_mod.deb
# dpkg -i skype_1.2.0.17-1_i386_mod.deb

Fatto. Facile e veloce. Skype funziona a dovere.

Ciao. Ilic.



23/03/2006

Ho dovuto reinstallare skype. Ho scaricato dal sito la versione 1.2.0.18-2.
In questa vesione al posto di cambiare la versione di libqt3c102-mt ho messo come dipendenze richieste:

Depends: libc6 (>= 2.3.2.ds1-4), libgcc1 (>= 1:3.4.1-3), libqt3c102-mt, libstdc++5 (>= 1:3.3.4-1), libx11-6 | xlibs (>> 4.1.0), libxext6 | xlibs (>> 4.1.0)

In sostanza ho lasciato solo "libqt3c102-mt", che poi è quello che ho io.
Per il resto o fatto tutto come indicato sopra (mettendo chiaramente i nomi corretti dei file (con la versione giusta).

Riciao. Ilic.

Ma qualcuno l'avrà mai letta 'sta roba ?
E soprattutto gli è stata utile ?
Per info, suggerimenti e indicazioni di qualunque genere scrivetemi.